Autor Tema: Porque el IRcap no es compatible con las versiones actuales del mIRC?  (Leído 14484 veces)

0 Usuarios y 1 Visitante están viendo este tema.

preguntando

  • Visitante
Buenas

Hace 1 dia, el desarollador del mIRC saco la version 7.1 Desde 1995, el mIRC no a cambiado mucho pero esta version tiene una cosa que en mi opinion para el mundo entero es bueno que es que soporta Unicode (caracteres no normales como el idioma japones y incluso no estoy seguro si la ñ es afectada o no) y aparte otras caracteristicas menores pero importantes.

Aparte de esta historia, yo no entiendo porque el IRcap solo es compatible con el mIRC 6.2 Entiendo que puede haber cambios en el mIRC que haya que sea dificil la transicion, pero llega un momento que hay que hacerlas aunque sea poco a poco.

La pregunta es esa: Por la version actual del IRcap no es compatible con las versiones actuales del mIRC?

Desconectado Lokiyo

  • Administrador
  • Héroe
  • *****
  • Mensajes: 739
  • Karma: +22/-2
  • Sexo: Masculino
    • El revoltijo de Lokiyo
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #1 en: Julio 31, 2010, 02:29:43 pm »
Creo que dejaré que GSi conteste a esa pregunta. Aunque creo que ya lo ha hecho varias veces.

Desconectado Lokiyo

  • Administrador
  • Héroe
  • *****
  • Mensajes: 739
  • Karma: +22/-2
  • Sexo: Masculino
    • El revoltijo de Lokiyo
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #2 en: Julio 31, 2010, 02:30:38 pm »
De todas maneras, yo estoy usando el IRcap 8.6 con mirc 7.1 y tampoco es q explote el ordenador, eh...

Desconectado veroushka

  • Novato
  • *
  • Mensajes: 21
  • Karma: +0/-5
  • Sexo: Femenino
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #3 en: Julio 31, 2010, 07:34:07 pm »
Si vas a el Mirc Option/ luego a IRC/Messages marcas la opción UTF-8 display y eso te soporta los unicodes o caracteres especiales.
Trabajo en la red de Undernet y algunos usan el Mirc 6.35 con el ircap 8.5 y no tienen problemas. Con la nueva versión 7.1 hay que esperar por GSI.
veroushka
#Ayuda en Undernet
La excelencia y expresión de un canal es la acción.

preguntas

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #4 en: Julio 31, 2010, 08:08:58 pm »
De todas maneras, yo estoy usando el IRcap 8.6 con mirc 7.1 y tampoco es q explote el ordenador, eh...
Si, se me olvido comentar perdon.

Va pero va a medias. Es lo que queria decir tambien pero no es totalmente compatible como obviamente se nota.

Desconectado Lokiyo

  • Administrador
  • Héroe
  • *****
  • Mensajes: 739
  • Karma: +22/-2
  • Sexo: Masculino
    • El revoltijo de Lokiyo
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #5 en: Agosto 01, 2010, 01:21:19 am »
¿Qué es lo que no te va?
A mí salvo algunos fallos en la alineación del texto en los canales, todo perfecto.

Desconectado GSi

  • Novato
  • *
  • Mensajes: 42
  • Karma: +7/-0
  • Creador de IRcap
    • IRcap
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #6 en: Agosto 01, 2010, 02:25:02 am »
Aún no he tenido tiempo de probar bien el 7.1 con el IRcap, pero de entrada no funciona la inicialización del script, el mIRC da errores en $read y hload, como si no existieran los ficheros. No recuerdo ninguna versión de mIRC que haya dado errores así en funciones tan básicas y usadas como $read.

Desde hace algún tiempo no me hace ninguna ilusión ver una versión nueva del mIRC, pues aparte de los habituales cambios de iconos de la barra y de las supuestas mejoras para Windows 7 y demás, lo que más veo son comandos que dan errores con los scripts que funcionan perfectamente en versiones anteriores.

Cada nueva versión del mIRC significa revisar todas las funciones del script y arreglar todo lo que antes funcionaba bien, y ahora no lo hace.

Cada nueva versión del mIRC es más lenta que la anterior, los scripts se ejecutan más lentamente, los gráficos se imprimen más lentamente. En la 7.01 se dice que es más rápido. Pues bien, acabo de hacer un test de velocidad imprimiendo gráficos. El mIRC 6.2 da 19 fps (fotogramas por segundo). El 7.1, da 12.

El IRcap tiene un interfaz gráfico, que he tratado de optimizar para que sea lo más rápido posible, llegando a ser en muchas ocasiones más rápido que su equivalente en "dialogs".

Es simplemente decepcionante ver como con cada versión de mIRC el interfaz funciona más lento, es como volver hacia atrás. Es cierto que en los últimos años los PCs han multiplicado su velocidad y que pese a que el mIRC cada vez es más lento, el avance del hardware compensa ese retroceso. Pero para mí, que soy el programador que se calienta la cabeza para que las cosas funcionen rápido, es decepcionante ver que todo se pone en contra.

Por ésta y otras razones decidí aguantar con el mIRC 6.2, a mi juicio mejor que las versiones actuales por su velocidad. Pero con la llegada de Windows 7 (más lento que XP), el unicode, los fallos corregidos del mIRC, etc., hay más necesidad de adaptarlo. Aún no he decidido si simplemente saco una nueva versión para el nuevo mIRC, o mantengo dos versiones para cada uno, explicando a los usuarios que quien siga usando XP debería usar mIRC 6.2 por ser más rápido, y quien no tenga más remedio que usar el Windows 7, pues que use el mIRC 7.01.

repuesta

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #7 en: Agosto 01, 2010, 07:12:38 pm »
Windows 7 (más lento que XP)
Todo lo que pusiste tenia sentido y perfecta logica hasta que lei esto.

Es impresionante como la prensa a podido manipular tanto a los usuarios y los desarolladores. Windows 7 es mas rapido que Windows XP. Es logico que con cuanto mas tiempo pasa, mas potente neccecita ser el hardware. MS-DOS tambien es mas rapido que Windows XP y puedes navegar por internet, grabar discos, escuchar musica, etc pero logicamente ni es facil ni da tanto espacio para desarolladores.

Es logico que vas a tener que poner un trabajo "extra" en tu script pero eso es lo que divide los desarolladores buenos y currantes a los vagos y malos.

Desconozco que hardware tiene tu ordenador pero yo ya ni puedo mirar a un ordenador que tiene XP. Todo esta tan.........revuelto. Quizas porque tu ordenador tiene presetaciones bajas no puedas disfrutar de lo que ofrece Windows 7 pero es totalmente otro mundo y merece la pena.

Ojala lo tomes en cuenta y podras actualizar tu script para que funione con versiones nuevas del mIRC.

Desconectado GSi

  • Novato
  • *
  • Mensajes: 42
  • Karma: +7/-0
  • Creador de IRcap
    • IRcap
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #8 en: Agosto 01, 2010, 09:25:58 pm »
A mí no me ha manipulado la prensa, yo uso scripts para testear la velocidad del mIRC, tests que miden la velocidad de los gráficos, de la impresion de textos, del scroll de ventanas, de computación pura y dura...

Y todos van más lentos en Windows 7 (y en Vista).

masrespuesta

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #9 en: Agosto 02, 2010, 12:28:54 pm »
A mí no me ha manipulado la prensa, yo uso scripts para testear la velocidad del mIRC, tests que miden la velocidad de los gráficos, de la impresion de textos, del scroll de ventanas, de computación pura y dura...

Y todos van más lentos en Windows 7 (y en Vista).

Especificamente, aunque dije usuarios y desarolladores, no decia de ti. Perdona si te lo tomaste personalmente.

Tambien en la version de 64 bits de Windows, hay applications 32 bits que pueden que en determinada situaciones sean algo mas lentos. Se nota? No.

Es lo que decias antes: El hardware de ahora en dia "compensa" por esas pequeñas lentidudes (que dudo que el usuario normal y corriente se de que cuenta; como la diferencia en programacion entre las instrucciones un "do....while" y un "for")

A mi me parece que scripts (o cualquier programa como por ejemplo 3DMark) de benchmark son bonitos.......pero se quedan ahi en bonitos. Lo que realmente cuenta son situaciones de vida real donde hay muchisimas variables de como va acutar un programa.

Pienso que el IRcap deberia parar de vivir en el pasado y acutalizarse para el futuro. Si realmente esta codificado correctamente, tendra la "velocidad" (entre comillas) extra en XP y la compatibilidad en 7 (por ejemplo).

Juan de paso

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #10 en: Agosto 09, 2010, 09:33:24 am »
GSI lleva más razón que un santo. Mi máquina es de hace dos años. Conseguí optimizar el vista (SO que traía del fabricante) al máximo, he tocado en todo lo que se podía tocar para acelerarlo y ahora está decente. Ahora bien, en esta misma máquina he probado cuatro SO (XP con todos sus sp, Vista con el SP2, Ubuntu y W7 Home Premium) y es cierto que el xp va má rapido, sin duda alguna. Por otro lado, he sido alf-op de algunos canales y ops de otros y coincido con GSI en que la mejor combinación es mIRC 6.2 con cualquier IRcap. Probé el 7.1 y da errores. Es tedioso estar continuamente corrigiendo errores teniendo en cuenta que las diferencias aportadas son muy pocas: cambios de iconos de la barra y de las supuestas mejoras para Windows 7 (que no uso).
Yo como GSI aguantaré con el mIRC 6.2

Mohair

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #11 en: Agosto 14, 2010, 09:40:13 pm »
La asociación IRcap 8.6 + mIRC 7.1 NO SIRVE, FUNCIONA MAL, Y TE LA ACABA CERRANDO WINDOWS.
Si te fijas, te lo dice en la pantalla de estado, arriba del todo, nada más conectar el mIRC:
Te indica que con el IRcap 8.6 tienes que usar el mIRC 6.2. Esto también te lo dice en la propia página del IRcap.
Yo lo sé porque instalé esta misma combinación y me volvió loco, windows me cerraba el mIRC, hasta que me di cuenta de que no eran compatibles y tuve que volver Mirc 6.2.
Por si sirve, tengo W-Vista.

Searcher

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #12 en: Agosto 18, 2010, 09:38:55 am »
yo actualmente estoy usando Ircap 8.6 + Mirc 6.35 y va sin nungun problema ;)

pero espero que pronto este disponible una nueva version de Ircap, compatible con Mirc 7.1

PD: el Mirc 6.2 esta considerado peligroso ya que tiene un potencial bug de seguridad, que solo esta resuelto en las versiones mas recientes.

byte

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #13 en: Diciembre 25, 2010, 09:41:39 pm »
Creo que muchos programadores deberían volver a la primera clase de la carrera para que les recordaran PARA QUE SIRVE LA PROGRAMACION. Que es resolver problemas y NO para crearlos. Siempre igual, si algo funciona bien ¿para qué tocarlo?. Hasta ahora mirc no había tenido problemas con el tema de las fuentes UTF-8 y demás, aparece la version 7.1 y hale, no funciona la Ñ (se puede cambiar, sí), aparece el nuevo windows-7 y otra tela de errores (lo del 7 será por el juego de los 7 errores ??).
Tal vez el autor del ircap deberia plantearse escribir una versión para solar irc...
En cuanto a los programadores de windows y de mirc, pues volver de nuevo a los origenes.

Searcher

  • Visitante
Re: Porque el IRcap no es compatible con las versiones actuales del mIRC?
« Respuesta #14 en: Enero 02, 2011, 11:05:30 pm »
Citar
Siempre igual, si algo funciona bien ¿para qué tocarlo?

eso se aplica para cuando en la programacion se hara un rework, y no para cuando algo esta desactualizado y necesita mejoras.

en este caso IRcap funciona bien con las ultimas versiones de Mirc pero tiene algunos problemas menores con el texto, por lo que hay que arreglarlo/actualizarlo, lo cual es uno de los conceptos de la programacion.

esta demas decir quer IRcap no funciona por si solo, ya que depende de Mirc, y si Mirc se actualiza, IRcap tambien debe hacerlo para soportar adecuadamente las nuevas versiones de este.

actualmente estoy usando IRcap 8.6 + Mirc 7.17 y funciona perfecto, salvo algunos detalles menores en los textos (como comente mas arriba), pero nada del otro mundo.

 

anything