Autor Tema: un codigo que no me funciona  (Leído 59 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Novatisima

  • Novato
  • *
  • Mensajes: 2
  • Karma: +0/-2
un codigo que no me funciona
« en: Febrero 17, 2020, 10:18:22 am »
Hola, he usado un código que he visto por aquí , pero no funciona, la verdad que me gustaría este codigo , si es posible que alguien me ayude , por que no  se nada de scriping , acabo de empezar en ircap , no se si sera posible o no pero la verdad es que falla , el codigo es este

Programa Baneo por colores                     
  Con la ayuda de  Quetzalcoatl y Cadaver preparado por Diablo

on 1:text:*:#: {
 var %a 1, %b $2 | while ($gettok(%b,%a,32)) { inc %a
if ($chr(3) isin $1-) { msg # $nick No use texto con COLORES estan prohibidos en #  | Ban -u600 $chan $address($nick,2) | kick $chan $nick }
  }
 }

Si alguien , pudiera hacerlo funcionar ,  le estaria muy agradecida  ;)  :)

Desconectado Quetzalcoatl

  • Miembro Junior
  • **
  • Mensajes: 54
  • Karma: +116/-2
  • HipercomputoHipermegared
    • elchatirc
Re:un codigo que no me funciona
« Respuesta #1 en: Febrero 17, 2020, 07:10:35 pm »
El problema es que ese código tiene el detalle de que empieza a evaluar después de la primera palabra(independiente si tiene o no color), y si en la frase se presenta un cambio de color actúa después de la segunda palabra en adelante.(Si la frase solo tiene el caracter de color en la primera palabra, sera imposible que sancione, a menos que se modifique)

Esto debido a que Diablo intentaba evitar sancionar a los que usaran nickCompletation del ircap, siendo que algunos usan el nick completation en toda la frase.
Para no alargar este post, respondere en el POST original de Diablo
http://foroircap.org/ayuda-scripting-ircap/duda-sobre-anticolores-de-ircap/15/

Saludos.